DSM Reporter showing "Attempted an unsupported operation" error

Document ID : KB000107891
Last Modified Date : 25/07/2018
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Issue:
When ends users try to modify or create a new report, the error "Attempted an unsupported operation." appears:

User-added image
Cause:
The problem is caused because DSM Reporter is installed on a remote Agent which has a language different than English configured (for example, Spanish).

Every management component (like DSM Explorer / Reporter) is not supported over Spanish language, the only supported languages are: English, French, German and Japanese. Here is the detail of the supported languages:

https://support.ca.com/us/product-content/status/compatibility-matrix/ca-it-client-manager-compatibility-matrix.html
Resolution:
In order to solve this problem, the language of the Agent needs to be configured back to English (or any other supported language) running the following command:

ccnfcmda -cmd SetParameterValue -ps itrm/common/localization -pn language -v lang

The value of lang specifies the desired language. Possible values are "enu" (English (U.S.)), "deu" (German), "fra" (French), and "jpn" (Japanese).