DSL Imported Application Processes With No Actions Or Flows

Document ID : KB000107143
Last Modified Date : 20/07/2018
Show Technical Document Details
Issue:
I created an export of a WebSphere Template Application. We will be using the template for on-boarding WebSphere Applications. I am able to import using DSL and create a NEW Application using the Template but:
1. The processes are empty; and
2. The environment Parameters are missing. I do see them in the Json file before importing but they are not showing up in the new application. In the Parameters Configuration for each Environment i see the message No parameters are defined for this environment.

 
Environment:
CA Release Automation 6.6.0.9640
Cause:
Process creation - When creating an application, you can create processes for the application too. We currently only support export/import of processes that use flows from a Shared Component. Only one Shared component flow can be placed on a Server Type inside a process. (A flow can contain multiple flows inside it, but only the top-level flow can be specified).

The above limitation/note is from here: https://docops.ca.com/ca-release-automation/6-6/en/deployment-automation/design-applications/create-applications-using-dsl
Resolution:
Create a new flow for each process that you have (ex: 3 processes = 3 new flows). In each new flow, add the same actions and flows used inside of the process. The new flow and the process should contain the same exact workflow. Then remove the flows and actions from your process and replace it with the newly designed flow. Publish the process. Based on the note in the product doc this should allow the process to be successfully imported.