Downloading attachment from a ServiceNow ticket results in Error parsing media type

Document ID : KB000084462
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
2017-12-06 22:45:36 pool-1-thread-171: REST: An error occured - after the request
Error parsing media type 'application/octet-stream,application/octet-stream;charset=UTF-8'
2017-12-06 22:45:36 An error occured - after the request
2017-12-06 22:45:36 Error parsing media type 'application/octet-stream,application/octet-stream;charset=UTF-8'
2017-12-06 22:45:36 pool-1-thread-171: REST: Clean up client

When downloading an attachment from a ServiceNow ticket the above error messages are displayed.

The ServiceNow Web Service call is returns a Content-Type header that the Jersey REST client does not understand. 

It only fails when attempting to retrieve the response media type.

However, retrieval of the response media type is not necessary for the success of the call.

In fact, if the error from retrieving the media type is ignored, the call will complete successfully. 

 
Environment:
OS Version: N/A
Cause:
Cause type:
Defect
Root Cause: ServiceNow Web Service call returns a Content-Type header that the Rest client does not understand. This functionality is available with version 4 of the RA WebService Agent and will not be fixed in version 3.
Resolution:
Update to a fix version listed below or a newer version if available as there will be no additional fixes for the RA WebService version 3 solution.
 

Fix Status: Released

Fix Version(s):
RA WebService Solution v4 - Available
Additional Information:
Workaround :
N/A