.Net agent does not work

Document ID : KB000115892
Last Modified Date : 26/09/2018
Show Technical Document Details
Issue:
After completing a .Net install and it show successful and manually installing the No Install .Net agent you are not able to get the .Net agent to run.
Environment:
Windows 2012, APM 10.7
APM !0.7
Cause:
The issue could be the COR_Profile environmental variable get hijacked by another app (ex. MS SCOM)
Resolution:
We found that the w3wp process was attaching the COR_PROFILER of another CLR profiler from MS SCOM. We had to modify the registry to remove references to the MS SCOM app.

In this image you can see that the COR_PROFILER was not using the COR_PROFILER that was defined in the installation.  Here is the one that should be in the Environmental Variables, COR_PROFILER={5F048FC6-251C-4684-8CCA-76047B02AC98}
User-added image

This dialog above came from the properties of the w3wp process in "Process Explorer"  Process explorer is a Microsoft Application that is free to download and easy to use.

Process Explorer
 
Additional Information:

Introscope .NET Agent Troubleshooting and Best Practices
https://comm.support.ca.com/kb/introscope-net-agent-troubleshooting-and-best-practices/kb000111638

How can we install the .NET Agent for 64-bit .NET Applications on Windows Server 2008 R2 by using NoInstaller files?https://comm.support.ca.com/kb/_How-can-we-install-the-NET-Agent-for-64bit-NET-Applications-on-Windows-Server-2008-R2-by-using-NoInstaller-files/KB000009387