DoSelect SOAP Web Service Calls can cause suspended queries in Service Desk

Document ID : KB000109906
Last Modified Date : 07/08/2018
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Issue:
After upgrading Service Desk to 17.1, DoSelect SOAP Web Service Calls can cause suspended queries in Service Desk. As a consequence Service Desk can become unresponsive because of many database agents getting busy.

See VDBINFO output below:

Agent #17 - (SEL) prov#6628_bpvirtdb_srvr @08/07/2018 09:47:49 with 1 in work
  SELECT_FULL (db_id=147383) SELECT call_req.open_date, call_req.id, call_req.ref_num, call_req.id FROM call_req ORDER BY call_req.open_date DESC
    SUSPENDED (10 of 10 recs) PROC(domsrvr) CNT(ServiceDesk)


DoSelect SOAP call example:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ser="http://www.ca.com/UnicenterServicePlus/ServiceDesk">
   <soapenv:Header/>
   <soapenv:Body>
      <ser:doSelect>
         <sid>1785083545</sid>
         <objectType>cr</objectType>
         <whereClause></whereClause>
         <maxRows>10</maxRows>
         <attributes>
            <string>ref_num</string>
            <string>status</string>
            <string>summary</string>
            <string>open_date</string>
            <string>resolve_date</string>
            <string>affected_service.name</string>
            <string>affected_service.system_name</string>
            <string>affected_service.asset_num</string>
            <string>affected_service.class</string>
            <string>affected_service.family</string>
            <string>affected_service.delete_flag</string>
            <string>assignee.last_name</string>
            <string>change.chg_ref_num</string>
            <string>group.last_name</string>
            <string>group.organization.name</string>
         </attributes>
      </ser:doSelect>
   </soapenv:Body>
</soapenv:Envelope>
Environment:
CA Service Desk 17.1
Cause:
It is a known issue in Service Desk 17.1.
Resolution:
There is a testfix available to be applied on top of Service Desk 17.1.
Make sure your environment runs Service Desk 17.1 and open a case at CA Support asking for the available testfix.

See details below:

PROB #: 0 FN: T52Y804 FT: D33 DATE: 25 Apr 2018 
PROBLEM SYMPTOM: WIN-MULTIPLE DOSELECT SOAP WEBSERVICE CALLS MAY RESULT IN CLIENT BECOMING UNRESPONSIVE