Question if need to create a new database if upgrading from 8.5 to 8.6

Document ID : KB000107499
Last Modified Date : 24/07/2018
Show Technical Document Details
Question:
We are upgrading from CA Gen 8.5 to 8.6. We are using the same database for 8.6 as we had used for 8.5 (also for 8.0). Do we need to run CEJOB04 and CEJOB05? Are there any differences with the objects and tables between 8.5 and 8.6?
Answer:
You do not need to run CEJOB04 because it builds a new DB. You do need to run CEJOB05 to load the schema tables. The schema did not change but there may be view changes. Basically, upgrading in-place only replaces the software. Be sure to install all PTFs in SMP/E before deploying the software. The CEINSTAL process will build your SQL, JCL, and PARMLIB libraries. You will need to make any user modifications made in prior releases to user exits, clist, and skeleton modules. Replace or move the contents of CEHBPLD1 to your CICS or IMS environment and you are ready to test.