Do we need the CA IPC to install the CA Datacom Support for MetaCOBOL ?

Document ID : KB000016606
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

The CA MetaCOBOL+ Version 1.1 is End of Life (EOL) and has not been certified with z/OS 2.1 and above.
The CA Datacom Support for MetaCOBOL Version 15.1 was certified with z/OS 2.1 and above and is optionally provided with the CA Datacom Version 15.1 installation.

Question:

When we tried to install the CA Datacom Support for MetaCOBOL Version 15.1, we received the GIM54701E and GIM28301E messages. Why does this error occur ?

GIM54701E ** ALLOCATION FAILED FOR CAVQLOAD - IKJ56228I DATA SET CAI.CAVQLOAD NOT IN CATALOG OR CATALOG CAN NOT BE ACCESSED.
GIM28301E ** ALLOCATION FAILED FOR CAVQLOAD, WHICH IS REQUIRED IN ORDER TO PROCESS LOAD MODULE ADRXIXIT. THE SYSMOD IS CABDF11.
GIM22601I APPLY PROCESSING FAILED FOR SYSMOD CABDF11.
GIM37001S ** APPLY PROCESSING STOPPED BECAUSE FUNCTION SYSMOD CABDF11 FAILED.
GIM20501I APPLY PROCESSING IS COMPLETE. THE HIGHEST RETURN CODE WAS 12

Environment:
z/OS 2.1CA Datacom Support for MetaCobol Version 15.1
Answer:

The CA Datacom and the CA Datacom Support for MetaCOBOL Version 15.1 needs the CAI.CAVQLOAD dataset for the installation.
And, the CAI.CAVQLOAD dataset is created by installing the CA IPC product.
So, you must install the CA IPC first.

Additional Information:

Note that CA MetaCOBOL+ Version 1.1 End of Life (EOL) was February 15, 2017. Please refer to
https://support.ca.com/us/product-content/status/announcement-documents/2016/ca-metacobol-end-of-life-announcement.html

For all CA mainframe product z/OS compatibilities including CA Datacom, please refer to z/OS Compatibility Matrix at
ftp://ftp.ca.com/pub/MSPSaccount/COMPAT/zos_compat.HTML