DMS-02104: The system cannot retrieve the requested document from the DMS

Document ID : KB000120654
Last Modified Date : 09/11/2018
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Issue:
When having set a "filestore folder size limit" in CSA, and this limit is reached, the afterwards uploaded documents cannot be downloaded anymore. 
A new window is opened with the message: 
DMS-02104: The system cannot retrieve the requested document from the DMS 

STEPS TO REPRODUCE 
1. Go to CSA - Documents and Search 
2. Set limit to f.e. 5 for the "File Store Directory Size Limit" field. 
3. In a project, upload a small document, this uploads fine 
4. Upload a document > 5mb, this also uploads fine 
5. Download the document from step 3, it reads fine. 
6. Download the document from step 4, it gives the reported DMS-02104 error message. 

Expected Results:
To able to read all attached documents.

Actual Results: 
DMS-02104: The system cannot retrieve the requested document from the DMS 
Cause:
It is seen that when the limit of the folder is reached as for CSA, a new folder is created called "Filesxxxxxx" where xxxxx is a number (the id of the uploaded document, CLB_DMS_FILES.ID). 
This folder is created at the same level as the "Files" folder. 
On retrieving the document from within the project, it cannot be found because it is still expecting this to be in the "Files" folder and not in the "Filesxxxxx" folder. 

Workaround is to remove the limit for the "File Store Directory Size Limit" in CSA or to copy the document into the "Files" folder.
 
Resolution:
This is reported as defect DE43210 and resolved in 15.5.1.204