Discussion Of Supported Oracle Client And Database Versions

Document ID : KB000020792
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

Due to recent document changes regarding oracle versions, this document was created in order to clarify those changes. This document discusses supportedversions of the Oracle client and server. It also describes the nature of problems you may see if working in a non-supported version of Oracle.

Solution:

Purpose: Due to recent document changes regarding oracle versions, this document was created in order to clarify those changes. This document discusses supported versions of the Oracle client and server. It also describes the nature of problems you may see if working in a non-supported version of Oracle.

Required Version of Oracle Client and Supported Version of Database Server:

Client

Oracle client version 11.2.0.3 must be installed on the App/Web server even if the database server is of a lower version.

  • On a single tier installation, installing an Oracle client which is a different version from the database software might cause irreversible damage both to the Oracle client and server. If installing on a single tier system the Oracle client and server should be the same version. If you are running on a multi-tiered environment then the database server can be any of the supported versions as long as the client on the App/Web server is 11.2.0.3.

  • On a single tiered install Windows and Oracle should both be entirely 32-bit. If installing a multi-tiered environment Windows can be 64-bit but the client should still be 32-bit on the APP/Web server. The remote database can be entirely 64-bit in that multi-tiered situation.

  • During the installation we are checking for the existence of a working Oracle client but we do not validate the version.

  • Oracle client version 11.2.0.3 can access an Oracle Database Server Oracle 9i Release 2 or later.
    See: http://www.oracle.com/technetwork/topics/dotnet/downloads/install112030-1440546.html

Database Server

Starting with BSI version 8.2 database server 10.2.0.4 is not supported anymore. Only 10.2.0.5 (out of Oracle 10g version) and up will be supported for the database server (again, not for the client). As for the problem you will face if working in a non-supported Oracle version, it will manifest as a connection problem in various places, could be services which are unable to load or a non-working GUI. The symptoms may vary but the error message willalways point to a connection/Oracle problem.

  • Database Server 10.2.0.5 or 11.1.0.7 are compatible with client 11.2.0.3 for multi-tiered installs.

  • If you have not upgraded to database server version 11.2.0.3 we recommend doing so.

32-bit VS. 64-bit

For all versions of BSI up to and including 8.2;

Single-tiered installs: We only support 32-bit Operating systems because we require the 32-bit Oracle client and you should not mix a 32-bit Oracle client with a 64-bit Oracle database on the same platform. Performance issues were found running the 32-bit Oracle database on a 64-bit platform, since this is not a recommended environment by Oracle this is no longer supported.

Multi-tiered installs: We support the 32-bit Oracle client on a 64-bit platform for the App/Web server. The database server can be 32-bit or 64-bit and the Oracle software can be 32-bit or 64-bit, but they should match the platform and follow Oracle's recommendations.

The minimum required database, version, character set, server prerequisites are listed in the table on this page.

RDBMS Vendor/
Database
Database Version/
Edition
Database Software VersionPlatformCharacter Set
OracleOracle 10 Standard, Enterprise, or RAC10.2.0.5Oracle certified operating systemAL32UTF8 WE8MSWIN1252
Oracle 11 Standard, Enterprise, or RAC11.1.0.7Oracle certified operating systemAL32UTF8 WE8MSWIN1252
Oracle 11 Standard, Enterprise, or RAC11.2.0.3Oracle certified operating systemAL32UTF8 WE8MSWIN1252

Install the 32-bit Oracle client listed here.

RDBMS Vendor/ Database Database Version/ Edition Database Software Version Platform Character Set*
OracleOracle 11 Standard, Enterprise, or RAC11.2.0.3Oracle certified operating system

Oracle Instant Client and Downloads

Please note that as of the time this document was written, Oracle requires an Oracle CSI number and login in order to download the full 11.2.0.3 database version. It is currently only available from Oracle's technical support site. The client MUST be installed from this full version. BSI requires the OLDDB libraries and these are NOT included as part of the Oracle instant client which is the only one which can be downloaded for free without an Oracle CSI. The instant client will not work with BSI.