Discrepancy in Audit log and EDB User count usage when a user with roles DevTest Administrator and System Administrator logs in to DevTest workstation

Document ID : KB000008548
Last Modified Date : 14/02/2018
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Issue:

(1) A user with roles DevTest Administrator and System Administrator logs in to workstation and logs off a little later.

(2) When the audit log is retrieved from the Server console >> Administration, it is not showing this user's entries for workstation

(3) The Enterprise Dashboard's User Usage count retrieved for the same time, is showing the user entry for workstation

Environment:
9.1 Registry connected to 9.5.1 EDB
Cause:

Possible defect in the product

Resolution:
  1. Stop all DevTest services (especially Registry)

  2. Update logging.properties and put the line 

    log4j.logger.com.itko.lisa.acl.AclDbUtility=DEBUG 

    after the line 

    log4j.logger.org.quartz=WARN

 

  1. Clear the existing Registry log (Default location is USERS_HOME_Folder\Administrator\lisatmp_9.1)

 

  1. Backup all DevTest databases - especially lisa and dradis 

 

  1. Run the following command on a lisa database that has the table ACL_AUDIT_LOG (i.e. via MySQL Workbench): 
    ALTER TABLE ACL_AUDIT_LOG MODIFY ROLE_NAME VARCHAR(255) 

 

  1. Start required DevTest services 

 

 

  1. The issue should be resolved. You can now remove debug logging in logging.properties.