Discovery Console models Citrix NetScaler as pingable

Document ID : KB000006065
Last Modified Date : 14/02/2018
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Issue:

CA Spectrum Discovery Console models the NetScaler device as pingable. The device has responded to an ICMP ping request, but not to a SNMP request.

Environment:
CA Spectrum 9.x; 10.x
Cause:

The Citrix NetScaler community string was configured to support to snmpwalk, sapwalk2, snmpgetnext, but not to snmpget command. CA Spectrum performs the snmpget to retrieve data from a remote host/device to model it.

 

snmpwalk -v2c -c <community> <IP Address> system | head

SNMPv2-MIB::sysDescr.0 = STRING: NetScaler NS11.1: Build 47.14.nc, Date: Jun 28 2016, 18:10:20

SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.5951.1

DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (874287150) 101 days, 4:34:31.50

SNMPv2-MIB::sysContact.0 = STRING: WebMaster (default)

SNMPv2-MIB::sysName.0 = STRING: NetScaler

SNMPv2-MIB::sysLocation.0 = STRING: POP (default)

 

SNMPv2-MIB::sysServices.0 = INTEGER: 72

 

 

snmpget -v2c -c <community> <IP Address> sysObjectID.0 

Timeout: No Response from <IP Address>. 

 

snmpget -v2c -c <community> <IP Address> sysDescr.0 

Timeout: No Response from <IP Address>. 

 

 

Resolution:

Configure the Citrix NetScaler community string on the device to support snmpget command.

Additional Information:

Configuring the NetScaler for SNMP v1 and v2 Queries