Discovery Agent not available sometimes at Discovery Wizard

Document ID : KB000005787
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Discovery Agent not available sometimes at Discovery Wizard

 

Discovery_Server.log

==============

[daConfigWorker-2] WARN  com.nimsoft.discovery.server.agent.config.DiscoveryAgentConfigUpdater - set_config failed for /nimsoftvitait8dom/Zurich/WSPMONBRZ002/discovery_agent: (2) communication error, I/O error on nim session (C) c

Environment:
UIM Any Version
Cause:

Slow Network performance between the Discovery Server and Discovery Agent

Resolution:

Insert this parameters at each Hub.cfg on hub section:

postroute_interval = 120
postroute_reply_timeout = 180
postroute_passive_timeout = 300
hub_request_timeout = 120
tunnel_hang_timeout = 300
tunnel_hang_retries = 3

 

Increase the java_mem_init and java_mem_max memory from the Discovery Agent/Server probes in Raw configuration

 

Restart the Discovery Server and Discovery Agent probes to force the connection and apply the changes

 

If all steps above does not help and the Intermittent connection problem persists, then check your Network Performance with the Network Administrator