Disable Link Attribute removes the display mapping image

Document ID : KB000033301
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue:

When setting a "Display Link Attribute" on a number attribute that has a display mapping image, the images disappear.

Steps to Reproduce:

  1. Go to Administration > Objects > Project (any other object would do) > Attributes > New 
  2. Call it "Link Test", Data Type "Number".
  3. For the display mapping section, choose a default bucket display mapping of Color White, and add two additional (such as red for negative numbers -9 to 0, green for positive from 0 to 9). Save the attribute. 
  4. Create another attribute, call it "Link Disable Status", Data Type "Number". Save the attribute. 
  5. Go to Home > Projects. 
  6. In the Project list (or any project based on Project object) click on Configure 
  7. For the list column section > Layout, add the Link Test attribute. 
  8. For the list column section > Fields, click on the Link Test properties. 
  9. Make sure that the "Images" checkbox is enabled. 
  10. For "Link", choose "Project properties" 
  11. For "Disable Link Attribute", choose "Link Disable Status". 
  12. Save all and go to portlet 

Expected Result: Image (diamond) with corresponding color from mapping is shown.

LinkExpected.png

Actual Result: Image (diamond) is not shown. Value is still displayed.

LinkActual.png

Cause:

Caused by CLRT-79278 

Resolution:

CLRT-79278 is being reviewed by Sustaining Engineering.

Workaround:

Avoid using a configuration to disable a link on a column that has a link which uses images.