DevTest services are running but cannot login to Portal

Document ID : KB000123989
Last Modified Date : 27/12/2018
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Issue:
All DevTest services are running, but it is not possible to login to the Portal.
The Portal page shows the Registry server name, but nothing happens when the username and password is provided.
Environment:
All supported DevTest releases.
Cause:
All DevTest services were up and running.
When looking at the Registry log files we verified there were several exceptions to connect to the database.
The database configured with the Registry was Derby.
Resolution:
Since the database was still the embedded database delivered with DevTest, Derby, we stopped all components and renamed the lisa.db folder under $DEVTEST_HOME/database/ directory.
When we restarted the Registry, it created a new database and no new exceptions in the log files.
After few seconds the Portal was restarted.
When the Portal was up and running we were able to login to it without issues.
Additional Information:
Apache Derby is provided as an out-of-the-box database so that you have a functioning system as you prepare to move to the enterprise database solution for your organization. Derby is not supported as an enterprise database solution.