DevTest Portal is not loading the list of deployed VSMs

Document ID : KB000076502
Last Modified Date : 04/04/2018
Show Technical Document Details
Issue:
In DevTest Portal, under Monitor, VSE, when trying to load the deployed virtual services in the Portal, we are receiving the following message:
"Failed to load data from the virtual service environment: VSE. Make sure that VSE is running."

The VSE service is up and running. In the VSE log files, we see the following information:
[ServerRequestResponder 1] WARN com.itko.lisa.net.RemoteMethodExec - InvocationTargetException on invoke getBundles 
java.lang.reflect.InvocationTargetException 
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) 
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) 
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) 
at java.lang.reflect.Method.invoke(Method.java:498) 
at com.itko.lisa.net.RemoteMethodExec.execute(RemoteMethodExec.java:57) 
at com.itko.lisa.net.ServerRequestHandler.processRMIMessage(ServerRequestHandler.java:533) 
at com.itko.lisa.net.ServerRequestHandler.access$600(ServerRequestHandler.java:70) 
at com.itko.lisa.net.ServerRequestHandler$5.run(ServerRequestHandler.java:451) 
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) 
at java.util.concurrent.FutureTask.run(FutureTask.java:266) 
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) 
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) 
at java.lang.Thread.run(Thread.java:745) 
Caused by: org.mapdb.DBException$HeadChecksumBroken: Head checksum broken, perhaps db was not closed correctly? 
at org.mapdb.StoreDirect.initOpen(StoreDirect.java:190) 
at org.mapdb.StoreDirect.init(StoreDirect.java:141) 
at org.mapdb.DBMaker$Maker.makeEngine(DBMaker.java:1504) 
at org.mapdb.DBMaker$Maker.make(DBMaker.java:1284) 
at com.ca.sv.bundle.BundleManagerMapdbImpl.makeDB(BundleManagerMapdbImpl.java:1017) 
at com.ca.sv.bundle.BundleManagerMapdbImpl.getDB(BundleManagerMapdbImpl.java:996) 
at com.ca.sv.bundle.BundleManagerMapdbImpl.getBundle(BundleManagerMapdbImpl.java:203) 
at com.ca.sv.bundle.BundleManagerMapdbImpl.lambda$getBundles$65(BundleManagerMapdbImpl.java:159) 
at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193) 
at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193) 
at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:175) 
at java.util.Iterator.forEachRemaining(Iterator.java:116) 
at java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801) 
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481) 
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471) 
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708) 
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) 
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499) 
at com.ca.sv.bundle.BundleManagerMapdbImpl.getBundles(BundleManagerMapdbImpl.java:161) 
at com.ca.sv.remote.VSBundleCreatorImpl.getBundles(VSBundleCreatorImpl.java:228) 
... 13 more 
Environment:
DevTest 10.x 
Resolution:
The issue was resolved by renaming /removing the VSE_2013 folders under $DEVTEST_HOME/vseBuilderSession/ and $DEVTEST_HOME/vseRecording/.

Steps followed:
*****************
. Stop the VSE Service.
. Navigate to the $DEVTEST_HOME/vseBuilderSession/.
. Rename the VSE_2013 folder to VSE_2013bkp.
. Navigate to $DEVTEST_HOME/vseRecording/.
. Rename the VSE_2013 folder to VSE_2013bkp.
. Start the VSE Service. When the VSE starts, new VSE_2013 folders will be created again.