DevTest - Address already in use: bind

Document ID : KB000108618
Last Modified Date : 30/07/2018
Show Technical Document Details
Issue:
Cannot start one or more DevTest components because a port is already in use.
In the log file, you find something similar to this:

============================================================================ 
| Exception: 
============================================================================ 
| Message: Unable to listen for requests on address/port xxxxx. It is either currently in use by another process or is not allowed by the operating system. 
---------------------------------------------------------------------------- 
| Trapped Exception: Address already in use: bind 
| Trapped Message: java.net.BindException: Address already in use: bind 
---------------------------------------------------------------------------- 
STACK TRACE 
java.net.BindException: Address already in use: bind 
at sun.nio.ch.Net.bind0(Native Method) 
at sun.nio.ch.Net.bind(Net.java:433) 
at sun.nio.ch.Net.bind(Net.java:425)
...

where xxxxx = the required port.
Environment:
All supported DevTest environments
Cause:
By default DevTest listens on all IP addresses associated with a physical machine.
This can cause issues especially with Virtual Machines or other setups with multiple in use IP addresses.
Resolution:
In the lisa.properties, uncomment the following line:
# lisa.net.bindToAddress=192.168.1.1

Adjust the IP address to the IP address DevTest should listen to.
The line should look something like this:
lisa.net.bindToAddress=192.168.1.1
 
Additional Information:
Not Applicable.