Device name is not getting updated in NFA

Document ID : KB000007769
Last Modified Date : 10/09/2018
Show Technical Document Details
Issue:

When you click on "Discover" option under "Enable Interfaces", it says "Profile not found" and below errors will be seen in logs:

 

INFO | jvm 1 | 2017/07/21 11:47:27 | java.lang.IllegalArgumentException: USM passphrases must be at least 8 bytes long (RFC3414 §11.2) 

INFO | jvm 1 | 2017/07/21 11:47:27 | at org.snmp4j.security.UsmUser.<init>(UsmUser.java:83) 

INFO | jvm 1 | 2017/07/21 11:47:27 | at com.ca.im.ra.snmpproxy.SnmpSession.addUsmUser(SnmpSession.java:118) 

INFO | jvm 1 | 2017/07/21 11:47:27 | at com.ca.im.ra.snmpproxy.SnmpRequest.checkProfile(SnmpRequest.java:115) 

INFO | jvm 1 | 2017/07/21 11:47:27 | at com.ca.im.ra.snmpproxy.SnmpRequest.sendSyncTableRequest(SnmpRequest.java:148) 

Environment:
Windows 2008 R2, 2012 R2.NFA 9.3.6 and Earlier
Cause:

Password used in SNMPv3 profile should be minimum of 8 characters. 

Resolution:

RFC3414 recommends user names, password, prive password, and auth password, all should be more then 8 characters.

NFA enforces this policy in the application and throws exceptions when the password length is less than 8 characters.

To fix this problem, change the password on device end and update SNMP profile which you have defined earlier with the new password.

 

 

Additional Information:

https://tools.ietf.org/html/rfc3414