Detailed Timesheet Button in the New UX does not work

Document ID : KB000093144
Last Modified Date : 26/04/2018
Show Technical Document Details
Issue:
When clicking on the 'Detailed Timesheet' button on a Submitted timesheet in the New User Experience (UX), no new pop-up is opened, and the Detailed Timesheet is never displayed. Any time period that has a submitted timesheet from a resource seems to be affected. 

Steps to Reproduce:
1. Log in to the PPM New User Experience
2. Click on the Timesheet icon
3. Click on the Review & Approve link on the top-right of the page 
4. Navigate to a time period that has a submitted timesheet 
5. From the 'Showing' drop-down, select 'All '
6. On the 'Open' button, deselect it so the button is no longer blue and all Open timesheets are no longer displayed (thus leaving only the submitted resource timesheets) 
7. Click on one of the resources with the submitted timesheet (this will open a small pop-up window on the bottom right with the timesheet tasks of the resource) 
8. Click on the Detailed Timesheet button 

Expected Results: The Detailed Timesheet to open and be displayed (it gets displayed as an overlay window that pops up when it does work) 
Actual Results: The Detailed Timesheet does not open and does not display, nothing ever shows. Clicking F12 in Google Chrome and clicking the Console tab displays an error message 'Cannot read property 'substring' of undefined. 
Cause:
This is caused by: DE35701
Resolution:
This issue is fixed in CA PPM 15.2 patch 6 (and higher) and 15.3

Workaround:
1. When the problem occurs, 'x' out of the resource information popup
2. Click 'SHOW ALL' next to 'Members'
3. Select 'All' from the drop-down menu again.
4. Filter for the submitted timesheets by deselecting the 'Open' button
5. Click the resource again to show the little window
6. Click the 'Detailed Timesheet', the Detailed timesheet then opens