DeploymentRuleSet.jar is invalid

Document ID : KB000016239
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

While loading the Autosys -IXP tool, we are getting the following error. 

DeploymentRuleSet.jar is invalid -- Can not Verify Deployment Rule Set jar due to certificate expiration. 

Question:

We cannot load the IXP tool on a client's machine. When we do we get the following error:

DeploymentRuleSet.jar is invalid -- Can not Verify Deployment Rule Set jar due to certificate expiration

Environment:
Windows and unix
Answer:

1. Run bash -login (if unix)

 

2. cd <Java Install Location>/Java/bin 

 

3. Run; 

 

./jarsigner -verify -verbose -certs <PATH_TO_JAR> 

 

Example: 

jarsigner -verify -verbose -certs c:\Java\DeploymentRuleSet.jar 

 

The resulting output should contain certificate details and expiry dates.

Example: 

 [entry was signed on 9/14/16 8:17 PM] 

X.509, CN="CA, Inc.", O="CA, Inc.", L=Islandia, ST=New York, C=US [certificate is valid from 3/8/16 11:00 AM to 3/9/19 10:59 AM] 

 

Upgrade Java if needed in order to get a new certificate.