deploying probe fails with a dependancy error

Document ID : KB000116722
Last Modified Date : 02/10/2018
Show Technical Document Details
Issue:
When trying to update nas probe in my lab environment to version 9.06,
I'm getting error: nas 9.06 Failed UIMserver Oct 2, 2018 8:21:00 AM Could not satisfy dependency P: vs2017_vcredist_x64, V: 1.00, T: ge


 
Environment:
UIM 9.X and earlier
Cause:
A prob package can be set to have a dependency before being installed.
When the probe is being deployed it will query the target controller for the list of installed packages to
make sure the dependency are there.
If the dependencies are not there it will try to install the missing dependencies from the local archive.
 
Resolution:
Make sure you have the dependency in the local archive for distribution.
If they are not there download them from the web archive.

If having a problem once downloaded try manually deploying the dependency before installing the final probe.