Dependent module /opt/freeware/lib/libiconv.a(shr4_64.o) could not be loaded.

Document ID : KB000008661
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Robot doesn't start on AIX 7.1

[xxxxxxxx:root:/opt/nimsoft/bin # ./niminit start 

Starting NimBUS 

Could not load program ./nimbus: 

Dependent module /opt/freeware/lib/libiconv.a(shr4_64.o) could not be loaded. 

Member shr4_64.o is not found in archive 

Environment:
UIM 8.51 Robot 7.91 on AIX 7.91
Cause:

Libiconv package 1.13.1-1 installed on that AIX box

 

[xxxxxxxx:root:/opt/nimsoft/bin # lslpp -L | grep -i iconv

bos.iconv.com 7.1.3.0 C F Common Language to Language

bos.iconv.ucs.com 7.1.3.15 C F Unicode Base Converters for

bos.rte.iconv 7.1.3.15 C F Language Converters

libiconv 1.13.1-1 C R Character Translation Library

Resolution:

Upgrade Libiconv package to version 1.15.1

 

[xxxxxxxx:root:/opt/nimsoft/bin # lslpp -L | grep -i iconv

bos.iconv.com 7.1.3.0 C F Common Language to Language

bos.iconv.ucs.com 7.1.3.15 C F Unicode Base Converters for

bos.rte.iconv 7.1.3.15 C F Language Converters

libiconv 1.15-1 C R Character set conversion

library, portable iconv