Deactivated or Locked users remain active in Jaspersoft

Document ID : KB000030821
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem:

The 'Create and Update Jaspersoft Users' job is not able to inactivate a user in Jaspersoft when it is deactivated or locked in the PPM application.  

Steps to Reproduce:

  1. Create a user with advanced reporting rights and synchronize to Jaspersoft using ''Create and Update Jaspersoft Users' job.
  2. Verify that user is synchronized to Jaspersoft
  3. Now deactivate or lock that user in PPM 
  4. Execute 'Create and Update Jaspersoft Users' job again with 'Full Sync' option selected 
Expected Result:  User to become inactive in Jaspersoft
Actual Result:  User remains active in Jaspersoft

Environment:

Applies to all supported PAS environments for specified releases.

Cause:

Caused by CLRT-78009

Resolution:

CLRT-78009 : Included in the fix for CLRT-77758

CLRT-77758 : Resolved in CA PPM 14.2 Generic Patch #2 and in CA PPM 14.3 

Additional Information:

Reference TEC1466848 : PPM 14.2 with Jaspersoft Problem with Special Characters in the Userid (fix for CLRT-77758)

Reference TEC1398937 : PPM 14.2 Generic Patch available to resolve reported issues