DB Error after AE SP7 upgrade

Document ID : KB000093520
Last Modified Date : 11/06/2018
Show Technical Document Details
Issue:
Database error occurring after the upgrade to 11.3.6 SP7

[04/19/2018 22:01:30] CAUAJM_E_18000 Database function call <ct_results> failed in <parseInternal> with return code: CS_CMD_FAIL 
[04/19/2018 22:01:30] CAUAJM_E_18016 Server: AUTOSYSXXXXXX 
[04/19/2018 22:01:30] CAUAJM_E_18018 Server message: Message number(207), Severity(16), State(1), Line(1), Message String: Invalid column name 'ac_jobterminated_n'. 
Environment:

1589 LINUX SYB 11.3.6 SP7
Cause:
Customer upgraded from build 1399 LINUX SYB 11.3.6 SP7 to 1589 LINUX SYB 11.3.6 SP7.
SP7 GA build is 11.3.6.1589

11.3.6.1399(sp7) is intermediate unsupported  build.  When you upgrade from this build, AEDB won't be refreshed to 1589 build because binaries are at same level,
but installation will be successful.
As AEDB is not refreshed , column AC_JOBTERMINATED is not added to schema ujo_rep_hourly, which caused the issue.
Resolution:
Solution1: 
Upgrade from intermediate build is not supported. So uninstall and install SP7 newly 
Solution2: 

Upgrade the database to SP7 GA level. To do that, follow the below steps :

1. Stop the AE services
2 - Run RefreshAEDB (perl RefreshAEDB.pl)
3. Start the AE services