Datmaker: Transformation map of DB type "File" not showing any functions in the drop down

Document ID : KB000010560
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

In some cases you may see that in the Transformation Map screen of Datamaker that the drop down for masking functions is EMPTY for the DB type of FILEMASK. This article will explain how to successfully create a transformation map for registered FILE or DB tables if this is encountered. 

Background:

Traditionally our tool Fast Data Masker's (FDM) GUI is used to for masking purposes for Databases for Files. However, there are cases where the Transformation Map screen of Datamaker is used to create and store the masking files in case the FDM GUI is not available for your environment or if you are using our Mainframe masking tool, which also does not have any interface.

Environment:
CA Test Data Manager- Datamaker
Instructions:

Prerequisite:

You already have a file or the tables for which the transformation map needs to be designed for are registered in GTDatamaker's version inside your Project.

 

Steps to reproduce this issue:

  1. Launch GTDatamaker.
  2. Go to Project-> Transformation Map.
  3. Click on the + button and create a map with DB type as "FILEMASK" and save it.
  4. Select the file just created from the drop down.
  5. Select the table/file from the left hand side.
  6. Click on the dropdown menu in the middle pane to select the masking function.

Observation:

The drop down is "EMPTY".

 

Reason:

Case 1: There are no Data Functions defined under the "Tools->Maintain Data Functions" screen for the DB type "File".

Case 2: While creating the Transformation map, you have accidentally selected "File" instead of "FILEMASK" as the DB type.

 

Resolution:

  1. Go to Tools-> Maintain Data Functions page. 
  2. Database, Data Type, Function, and Description columns will come up.
  3. If there are no entries for DB type "FILEMASK", create them manually, or get in touch with support to get the necessary backend statements to add them into your Repository Database.

 

Steps to create them manually:

  1. Click on the green plus button. It will take you to the bottom of the list.
  2. Choose Database Type from the drop down list. For example, FILEMASK. 
  3. Choose the appropriate Data Type, masking function name as per the documentation, and add an appropriate description.
  4. Click on the save button. You can now see the masking function in the drop down list of the transformation map screen for the map of the type FILEMASK.
Additional Information:

If you face any issues or have any questions about the steps, please open a support case by going to https://support.ca.com/us.html or by calling customer care at http://www.ca.com/us/services-support/ca-support/contact-support.html.