Datamaker: Error while connecting to ALM Service

Document ID : KB000005216
Last Modified Date : 14/02/2018
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Issue:

While trying to register a project in Datamaker as 'BPT from HP ALM', I am getting an error message of 'Start session failed'.

start session failed.png


Steps to Reproduce: 
1. In Datamaker, register a project. 
2. Choose 'BPT from HP ALM' in the 'Register into project' screen. 
3. In the 'Register BPT tab', browse for a table or enter a table name. 
4. In the 'Choose ALM Object' window, enter in a URL and Hostname. 
5. Click the green check mark in the bottom right hand corner. 
Actual Result: After entering credentials and server name, we get the error message: Start session failed.

Environment:
CA Test Data Manager (TDM)- Datamaker & HP ALM
Cause:

If you are using a direct HP ALM URL in the connection details, you will receive an error message. You need to use the HP ALM Service URL. 

Resolution:

To resolve this, please do the following:


1. Start the HP ALM Service. 

2. Verify service was properly started by opening http://localhost:8095/ in web browser. 
- It should display ALMService Service page which list wsdl paths and c# and visual basic example. 

3. In Datamaker, choose the HP ALM object screen, provide following information, and click the connect button. 

connect button alm issue.png

4. Enter in URL http://localhost:8095/ALMService 
- User: HP-ALM login user 
- Password: HP-ALM user Password 

5. On connecting, Domain and Project should be auto populated.

Additional Information:

If you experience any further issues, please open a support case by going to https://www.ca.com/us/services-support/ca-support/contact-support.html