Datamaker: Error opening DLL library aes_dll.dll for external function

Document ID : KB000007706
Last Modified Date : 14/02/2018
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Issue:

When trying to connect to connect to the repository on a new installation of Datamaker, I received the following message: 

Error opening DLL library aes_dll.dll for external function at line 15 in function uf_enc of object u_external_function_win32. 

I set up and connected to the repository using these directions:
https://docops.ca.com/ca-test-data-manager/4-4/en/installing/install-ca-test-data-manager/install-the-repository 
https://docops.ca.com/ca-test-data-manager/4-4/en/installing/install-ca-test-data-manager/connect-to-the-repository 

Environment:
CA Test Data Manager (TDM)- Datamaker
Cause:

Most AES.dll errors are related to missing or corrupt AES.dll files. Improperly shutting down your PC or getting a virus infection could corrupt the AES.dll, which could lead to DLL errors. When your AES.dll file becomes corrupt, it cannot be loaded properly and will present an error message. Other times, AES.dll file errors could be related to issues in the Windows registry. Broken DLL file references can prevent your DLL file from registering properly, giving you a AES.dll error. These broken registry keys can be as a result of a missing DLL file, moved DLL file, or an leftover DLL file reference in your Windows registry from an unsuccessful software installation or uninstallation.

Resolution:

We recommend following the troubleshooting and resolution steps in the 'How to fix AES.dll errors' section in this document: http://www.solvusoft.com/en/files/missing-not-found-error/dll/windows/cosmi-corporation/perfect-zip/aes-dll/  

Additional Information:

If you experience any further issues, please open a support case by going to https://www.ca.com/us/services-support/ca-support/contact-support.html.