Datamaker Connection Error: Login failed for user 'sa'. The user is not associated with a trusted SQL Server connection.

Document ID : KB000005192
Last Modified Date : 14/02/2018
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Issue:

When trying to setup a repository connection profile in Datamaker, I am receiving the following error message, despite being able to connect to SQL Server outside the tool: 


Connection failed: 
SQLState: ‘28000’ 
SQL Server Error: 18452 
[Microsft][SQL Native Client][SQL Server]Login failed for user ‘sa’. The user is not associated with a trusted SQL Server connection. 

I followed these steps in the documentation for connecting to the SQL Server Repository: https://docops.ca.com/ca-test-data-manager/4-4/en/installing/install-ca-test-data-manager/connect-to-the-repository 

Environment:
CA Test Data Manager (TDM)- Datamaker
Cause:

This error message could be caused by a few different things, so we would normally ask the following troubleshooting questions to narrow down the root cause: 
1. Did you review any SQL Server or Microsoft knowledge base articles for this error? For example: https://support.microsoft.com/en-us/help/555332/-login-failed-for-user-error-message-when-you-log-on-to-sql-server 
2. Are you trying to use Windows authentication? 
3. Do you have SQL Server Management Studio and can you login using sql server authentication to that user in the error message? 
4. Is the user enabled for sql server authentication? 
5. Are your TCP/IP settings under SQL Server Manager set up? 
6. Can you create a DSN-Less connection? 
7. Did you read the documentation for installing and connecting to the TDM repository? https://docops.ca.com/ca-test-data-manager/4-4/en/installing/install-ca-test-data-manager/install-the-repository 

Resolution:

A common cause we see for this error is that your connection string details or format is incorrect.

For example:
If you have <servername>\SQLEXPRESS when your instance is actually SQLEXPRESS2014, the connection string should be changed to  <servername>\sqlserver2014. 

We also highly recommend reviewing the following knowledge documents with your DBA to resolve the issue:
https://support.microsoft.com/en-us/help/2121736/error-message-when-you-try-to-authenticate-an-odbc-connection-to-your 
https://support.microsoft.com/en-us/help/555332/-login-failed-for-user-error-message-when-you-log-on-to-sql-server 

Additional Information:

If you experience any further issues, please open a support case by going to https://www.ca.com/us/services-support/ca-support/contact-support.html.