Datamaker : Repo connect "Failed to validate version" error

Document ID : KB000115624
Last Modified Date : 21/09/2018
Show Technical Document Details
Issue:
Logging into the repo via Datamaker is failing with error "Failed to validate version"

Environment:
Supported TDM Version connecting to an MS SQL based repo (GTREP).
Cause:
Lack of permissions to the pk_gtrep_lic schema.
Resolution:
Ensure that the user which you are connecting to the repo with has the same permissions as the gtrep (dbo) user.

This error generally indicates that the user doesn't have acces to the pk_gtrep_lic schema and the pk_gtrep_lic.verify_version() function fails to return the expected data.

Permissions can be validated by running the following query from SQL Server native utilities (example: SQL Server Management Studio):
 
use gtrep;
select pk_gtrep_lic.verify_version() from gtrep_system;