data_engine unable to start - COM Error [0x80040154] Class not registered - [Provider] Class not registered

Document ID : KB000047107
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 

After a sever reboot, the data_engine probe fails to start up with the following error in the data_engine.log:

Sep 30 19:22:03:929 [2052] de: [main] has connected to database 
Sep 30 19:22:03:929 [2052] de: Database script - processing 3 database scripts 
Sep 30 19:22:03:929 [2052] de: Database script - Module: [ NIS_BASE ], File: [scripts\sqlserver_nis_base_create.sql], run check: [yes], run script: [ no] 
Sep 30 19:22:03:945 [2052] de: [main] ExecuteRecords - 1 errors 
Sep 30 19:22:03:945 [2052] de: (1) ExecuteRecords [Provider] Class not registered 
Sep 30 19:22:03:945 [2052] de: COM Error [0x80040154] Class not registered - [Provider] Class not registered

There were also a handful of other probes that were unable to start (because they rely on data_engine to be running).

 

Environment:  

This issue was found using UIM 8.4 and Windows 2008 R2, but the information is generally applicable to most versions of UIM.

 

Cause: 

This scenario was caused by one or more corrupted .dll files in the C:\Windows\System32 directory.

 

Resolution/Workaround:

1. Disable the UIM service on the primary hub

2. Run this command to search for issues on the file system (search only)

SFC /VERIFYONLY

3. Should that return an integrity violation, run the following to correct it:

SFC /SCANNOW

4. After completion ("Windows Resource Protection found corrupt files and successfully repaired them." ), start the UIM service back up on the primary hub

 

The data_engine probe should then be able to start up and connect with the database.

 

Additional Information:

 

System File Check (SFC) - https://msdn.microsoft.com/en-us/library/windows/desktop/aa382541(v=vs.85).aspx

Using SFC - https://support.microsoft.com/en-us/kb/929833