Database installation errors when upgrading Jasper to 6.4.3

Document ID : KB000116934
Last Modified Date : 04/10/2018
Show Technical Document Details
Issue:
When trying to upgrade JasperSoft to 6.4.3 errors are seen when trying to log into existing MySQL database.
Error seen: Database is not valid
Environment:
Jasper 6.4.2
MySQL Database
Cause:
A bug in the code when dealing with mysql databases causes this error to be seen.
Resolution:
This will be resolved in a future release of CABI.
Workaround:

Before starting the upgrade installer, execute the below query in the mysql database:


ALTER TABLE jasperserver.JIResourceFolder RENAME jasperserver.JIRESOURCEFOLDER; 

Before the install is executed (where the install actually runs) , however, the following query must be run:


ALTER TABLE jasperserver.JIRESOURCEFOLDER RENAME jasperserver.JIResourceFolder;