Data Migration Tool for ARA Upgrade gives error: Could not load file or assembly 'Oracle.DataAccess'

Document ID : KB000088210
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Could not load file or assembly 'Oracle.DataAccess, Version=4.112.3.0, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT:

When upgrading ARA, there is a step which uses a Data Migration tool for the database. When using this tool, the following error message may be produced:
 
Could not load file or assembly 'Oracle.DataAccess, Version=4.112.3.0, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

This error message indicates you do not have the correct version of Oracle DataAccess installed which is required for the Data Migration tool to execute.

 
Environment:
OS Version: N/A
Cause:
Cause type:
Configuration
Root Cause: The correct version of Oracle Data Access is not installed which is required by the Data Migration tool.
Resolution:
ODP.net 4 (included in Oracle ODAC) needs to be installed.
Attempt to run the Data Migration tool again after the above installation.

Reference

64-bit Oracle Data Access Components (ODAC) Downloads



Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A