Data Collector is not connecting

Document ID : KB000009206
Last Modified Date : 14/02/2018
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Issue:

A Data Collector is showing as "Not Connected" in Performance Center console, even though the dcmd process is running and has been restarted

Environment:
CA Performance Management, all versions
Cause:

There is an issue with activeMQ, and restarting only the dcmd process may not resolve the issue

Resolution:

1. Stop dcmd, as follows; /etc/init.d/dcmd stop

2. Stop activeMQ, as follows; /etc/init.d/activemq stop

3. Delete or rename the "/opt/IMDataCollector/apache-karaf-2.4.3/data" folder (path may vary)

4. Start dcmd, as follows; /etc/init.d/dcmd start  (this will also start activemq)

 

The Data Collector should now show as "Collecting Data" in the CA Performance Center console