Data Aggregator Not Syncing with Performance Center

Document ID : KB000038971
Last Modified Date : 14/02/2018
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Issue:

Data Collectors will not connect. Recycled the environment; shut down PC,DC,DA,DR in that order; restarted DR, DA, DC, PC, but the data collectors will not connect. They initially connect but then disconnect after a few seconds. I recycled the environment twice to check this out but the collectors will not connect up.

Environment:  

CA Performance Management 2.4

Cause:  

They were picking up 200 metrics per device on environmental items (fans, power, etc) for thousands of devices. A decision was made to put 2M device metrics went into retirement …at the same time, unbeknownst to them, an additional 770k QoS classmap items were added overnight. That’s a net change of 3 million items in the database, which vertica could not keep up with. 

Resolution:

Stopped the Data Aggregator and the Data Collectors. Removed ~ 770K Qos Classmap items that were added due to a core upgrade configuration push and a discovery. Restarted the Data Aggregator and then restarted the Data Collectors