CWWJP0015E error messages appear in the WebSphere servant log at startup with Web Viewer 12.0 and above

Document ID : KB000017379
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

CWWJP0015E error messages can appear in WebSphere's servant log when WebSphere is initializing. The messages report an incompatibility between the JavaPersistence API (JPA) provider used by WebSphere and the JPA provider delivered as part of CA Output Management Viewer 12.n.

Solution:

For database access, CA Output Management Web Viewer 12.n uses the Java Persistence API (JPA) provider included as part of the EclipseLink 2.1.1 open-source project instead of the JPA provider delivered as part of WebSphere. This can cause some conflicts when WebSphere initializes its JPA environment. The log for the WebSphere servant process will show the following message:

CWWJP0015E: An error occurred in the org.eclipse.persistence.jpa.PersistenceProvider persistence provider when it attempted to create the container entity manager factory for the CAERMWebViewerPU persistence unit. The following error occurred: java.lang.ClassCastException: org.eclipse.persistence.jpa.PersistenceProvider incompatible with javax.persistence.spi.PersistenceProvider

This appears to have no impact on the functioning of Web Viewer. However, the error can be eliminated by following the instructions found in IBM article PM26361. Note that in step 10 of the IBM procedure, you must specify "CAOMWebViewer12_ear" (or whatever application name was chosen for Web Viewer when it was installed). Also, when running WebSphere on z/OS, there is an extra step between #5 and #6, which is to select the "servant" region.