Custom Reports Scheduled Emails Not Emailed

Document ID : KB000045228
Last Modified Date : 14/02/2018
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Issue/Problem/Symptoms: 

Custom Report emails Scheduled through the Custom Report Wizard do not get sent out on scheduled.

When checking the \Reporter\logs\Manager ServiceLog*.log file around the time the report is scheduled you will may see this error:
 
0:30:14 2 - Report Scheduler - :
NQS_EMS_00701: Expected content type application/pdf but received
text/html;charset=UTF-8

Environment:  

Network Flow Analysis, versions 9.1 and above, any architecture

Cause: 

NFA database user table containing incorrect permission for admin user

Resolution/Workaround:

1. RDP to the NFA Console server.
 
2. Login to the 'reporter' database by running the comamnd below from a Command Prompt:

mysql -P3308 reporter

3. Check the 'user_definitions' table to see if the 'admin' user has a 'userlevel' value of '1' with the query below:

select userlevel, name from user_definitions where name ='admin';
 
4. If it is not '1' please update it with the query below:

update user_definitions set userlevel=1 where name='admin';
 
5. Then either wait for the next scheduled email to be sent, or shcedule a new Custom Report email to test and verify the email gets sent.  You can also check the 'Manager ServiceLog' file to verify the errors are no longer seen.