Custom Portlets Broken After Upgrade to 15.5

Document ID : KB000117209
Last Modified Date : 09/10/2018
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Issue:
We have two portlets that were destroyed during the upgrade to 15.5. Both of these portlets are copies of CA portlets. We created copies then used to copies to 'customize' them for our needs. The upgrade wiped out the portlets completely. When in the Admin side of the tool, and clicking on the portlet to see the definition, it returns completely blank and has and Error flag. 
Cause:
The PPM OLTP database schema was change to accomodate enhancements that our customers requested; some of the tables used in the NSQL query for the portlets were deprecated or changed. You can review the database schema changes documents to find out what tables were deprecated and/or how they were changed.
Resolution:
You will need to modify the custom portlets so the NSQL queries are not using the deprecated tables and are using the tables whose structure was changed in the new release correctly.