Custom Multi Valued Lookup type attributes do not display any values in Portfolios

Document ID : KB000033245
Last Modified Date : 14/02/2018
Show Technical Document Details

Symptoms:

Custom Multi Valued Lookup type attributes do not display any values in Portfolios. We created a custom Multi Valued Lookup (MVL) type attribute, but even after running the Portfolio sync this field remains blank.

Steps to Reproduce:

  1. In Administration, go to objects and select project
  2. Add a new attribute as Multi Valued lookup and link it to any existing lookup
  3. Go to views and add the attribute to any edit page of the project
  4. Select Portfolio Investments object
  5. Select the Attribute Registry tab and add the custom attribute
  6. Select the Views tab, and click on Layout of the Portfolio Investment list
  7. Add the attribute to the selected columns
  8. Go to Home, Projects. Select one or more projects and select one or more values in the custom MVL attribute
  9. Go to Home, Portfolios and create a new portfolio
  10. Manually add one or more projects where the custom MVL attribute has been evaluated
  11. Click on Sync
  12. Go to Investments tab and view the results for the project you added with a custom MVL value
Expected Result: The custom MVL attribute is populated with values
Actual Result:  The custom MVL attribute is blank 

Environment:

Applies to all supported PAS environments for specified releases.

Cause:

Caused by CLRT-75202

Resolution/Workaround:

The Sustaining Engineering and Development teams have reviewed this issue and determined that this is a design issue.  A user story will be created for review and planning by Product Management to be addressed in a future release.

Until this issue is resolved in a future release, do not register this type of custom attribute into the Portfolio Registry so that users will not see the attribute with a blank value.