[CRWEB00000119] Error When Running BOXI Reports installed in localized (PTBR) language

Document ID : KB000008173
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Error launching some of the CA SDM out of the box crystal or WeBI reports:


Error in English:

Unknown DB Connector Error []
--- Error Code:0 [CRWEB00000119]

Error in Portuguese:

Erro de conector de banco de dados desconhecido []
--- Error Code:0 [CRWEB00000119]

Environment:
Service Desk Manager 12.9 / 14.1CABI installed in English + non English (example: PTBR)
Cause:

This is caused when the browser locale preferences in BOXI is set different from English in a localized BOXI installation.

Resolution:

. Have the Browser added with appropriate locale (ex: Portuguese) to it

. Infoview/ BI Lauch Pad / CMC preferences should be set to below (after logging into CABI via a Browser)

1) Set CABI Preferences -> Product Locale to Browser Locale

2) Set CABI Preferences -> Preferred Viewing Locale to Browser Locale

3) Save

4) Logoff of Infoview / BI Lauch Pad / CMC and login again.


* Note that this configuration is individual for each user and so it should be done by each of them.

 

Additional Information:

Localization of reports folder structure (tree control), report titles, and descriptions in the List view of Business Intelligence Launch Pad are not supported.

https://wiki.ca.com/display/CASM1401/CA+Service+Desk+Manager+Known+Localization+Issues#CAServiceDeskManagerKnownLocalizationIssues-UnabletoViewtheCAServiceDeskManagerReportsinLocalizedLanguages

https://support.ca.com/us/download-center/solution-detail.html?aparNo=RI77353&os=ANY&fc=1&actionID=3