CPs/WPs fail to start if not started in name sequence

Document ID : KB000088095
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Service '[WPx/CPx]' is already running

If WPs (and CPs) are not started in the sequence of their names they will fail to start.

Investigation

Configure 3 WPs (WP1, WP2 and WP3) in the Service Manager Dialog (SMD) and link it to the Automation Engine (AE) environment.
  1. Start WP1 & CP1 and connect to the Automation Engine, either from Automic's Web Interface (AWI) or the Java User Interface (UI).
  2. Start WP3 from the User Interface > System Overview > Automation Engine
0EMb0000001UtR6.png
 
or from the AWI > Administration > Automation Engine Management > Processes & Usage.
0EMb0000001UtRB.png

The process will be started as 'WP002', and the original 'WP002' will now display as 'WP003':

User Interface:
0EMb0000001UtRz.png
 
AWI:
0EMb0000001UtRp.png
  1. Then try to start WP3.
Results

Expected: WP3 should run even if not started in the sequence of WP names.

Actual : WP3 will fail to start with the error below:
0EMb0000001UtS4.png
0EMb0000001UtR1.png
Environment:
OS Version: N/A
Cause:
Cause type:
By design
Root Cause: WPs and CPs are started in the sequence of their names.
Resolution:
When starting a process from the System Overview or the Administration perspective, the lowest available combination of WP name/port from ucsrv.ini is used by default.

There is no method provided to start the process 'WPx' explicitly.

When starting a process in the AWI or the UI, the Service Name is sent to the Service Manager (SMgr).

The SMgr tries to start this service, and reports back if it is already running. There is however, no correlation between the service name and the process name.

Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
Use the Service Manager [Dialog] to start the WP.