CP encounters maximum connects and then ends abnormally

Document ID : KB000087694
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
U00003398 A maximum number of '9999' connections is supported.

When Agents are connecting to the Automation Engine, a CP fails when it reaches the maximum connections. 

If this occurs you will see the following error listed in the CP:

U00003406 Client connection '39065(10000)' from '? has logged on to the Server.
U00003398 A maximum number of '9999' connections is supported.
U00003407 Client connection '39065(9999)' from '?' has logged off from the Server.

With the corresponding error listed in the PWP:

U01002204 Message ID '4f' at position '32034' has been assigned the invalid length '1002205'.
U00003472 Connection to Server '?' has been closed.

Cause:
Cause type:
Defect
Root Cause: The maximum number of connections needed to be higher than 9999. Fix versions increases connections to 150,000.
Resolution:
This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: Released

Fix Version(s):
Automation Engine 12.0.0 HF3 - Available
Automation Engine 11.2.3 HF1 - Available
Additional Information:
Workaround :
Add additional CP's to keep the connections per CP under 9999.