Could not connect to generate Ad Hoc report in JasperReports 6.3

Document ID : KB000005000
Last Modified Date : 14/02/2018
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Issue:

The following error is displayed when generating Ad Hoc Availability report:

Could not connect to address=(host=breeze-w2k8vm3)(port=3306)(type=master) : breeze-w2k8vm3 

Environment:
CA Spectrum 10.2 and JasperReports 6.3
Cause:

The spectrum_domain_ds Data source is pointing to the wrong SRM (Spectrum Report Manager) hostname.

 

spectrum_domain_ds_setting1.png

Resolution:

Manually change the spectrum_domain_ds Data source settings.

 

1. In the Home page of JasperReports, Data Sources, click on View list

JasperReports_data_sources.png

2. Right-click the spectrum_domain_ds item and choose Edit.

edit_spectrum_domain_ds.png

 

3. Supply the Host, Port, and Database information.

Host: SRM hostname

Port: 3306

Database: srmdbapi

spectrum_domain_ds_changed.png

 

4. In case test connection fails, follow the TEC1556623 - MySQL Connector/ODBC Test fails while configuring the Ad Hoc Report ODBC driver

 

5. Save the changes.