Copy Status Report fails when a default value is set to ID attribute of Status Report Object

Document ID : KB000048083
Last Modified Date : 18/06/2018
Show Technical Document Details
Issue:

Status reports are not copied successfully when default value is set to ID attribute of Status Report Object. This occurs for custom attributes.

Steps to Reproduce:

  1. Make sure PMO is installed on the ppm instance before proceeding to Step #2
     
  2. Navigate to Administration, Studio: Objects, Status Report, Attributes
     
  3. Click on ID attribute within the attribute list
     
  4. Set the default field with a value
     
  5. Click 'Save' button
     
  6. Navigate to Home, Project, open any project, Properties Tab, Status Reports
     
  7. Make sure there are at least 2 Status Reports created, if not create new Status Reports
     
  8. Open any Status Report
     
  9. On the right section of the screen, click Actions hyperlink, click Copy

    Copy Status Report page: Select any Status Report radio button, then click 'Save And Return' button
    Error displayed: ODF_0604: An error occurred when copying objects. Please check your object mapping definition and try again.
     
  10. Go to step 4, clear default value field. Click 'Save' button
     
  11. Try to copy Status Report again (Repeat Step through 6 if required). The same error is displayed

Expected Result: The status reports should be copied successfully

Actual Result: ODF_0604: An error occurred when copying objects. Please check your object mapping definition and try again.

Cause:
This issue is caused by: CLRT-75031
Resolution:

This issue is fixed in CA PPM 14.2.

WORKAROUND: None