Cannot install Cabi on Linux: Controller: Probe 'cabi' (command = <startup java>) returns no-restart code (42)

Document ID : KB000100143
Last Modified Date : 07/06/2018
Show Technical Document Details
Issue:
I have configured the CABI for uim, using the cabi probe (bulnded) as per Documentation.

And I have already checked the following KB's:

cabi_external probe will not start
Cabi probe v3.0 deployment problems
Unable to use UIM CA Business Intelligence Dashboards (error 403)
After deploying the CABI probe to a robot we are getting the following: (command = <startup java>) returns no-restart code (42)
Wasp probe used with CABI won't start. Controller: Max. restarts reached for probe 'wasp' (command = <startup java>)

However, the probe does still not start with the below error:

May 18 13:39:55:220 [Thread-2, cabi]
May 18 13:39:55:220 [Thread-2, cabi] BUILD FAILED
May 18 13:39:55:220 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:187: The following error occurred while executing this line:
May 18 13:39:55:220 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:248: The following error occurred while executing this line:
May 18 13:39:55:220 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:257: The following error occurred while executing this line:
May 18 13:39:55:220 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:262: The following error occurred while executing this line:
May 18 13:39:55:220 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:279: The following error occurred while executing this line:
May 18 13:39:55:220 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:326: The following error occurred while executing this line:
May 18 13:39:55:220 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:838: Installation of CA Business Intelligence failed
May 18 13:39:55:220 [Thread-2, cabi]
May 18 13:39:55:220 [Thread-2, cabi] Total time: 4 minutes 54 seconds
May 18 13:39:55:224 [main, cabi] cabi installer completed with exit code=1 [time taken=4 minute(s) 54 second(s) (294378 ms)]
May 18 13:39:55:225 [main, cabi] (42) , CABI installer failed with exit code=1
at com.ca.cabi4uim.installer.CabiInstaller.runCabiInstaller(CabiInstaller.java:247)
at com.ca.cabi4uim.Probe.doConfigAndRunCabiInstaller(Probe.java:368)
at com.ca.cabi4uim.Probe.setupCabiInBundledMode(Probe.java:315)
at com.ca.cabi4uim.Probe.setupcabi(Probe.java:281)
at com.ca.cabi4uim.Probe.initOnTimer(Probe.java:620)
at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:418)
at com.ca.cabi4uim.Probe.run(Probe.java:805)
at com.ca.cabi4uim.Probe.main(Probe.java:111)
May 18 13:39:55:239 [main, cabi] activating wasp...
May 18 13:39:55:243 [main, cabi] (42) , CABI installer failed with exit code=1
at com.ca.cabi4uim.installer.CabiInstaller.runCabiInstaller(CabiInstaller.java:247)
at com.ca.cabi4uim.Probe.doConfigAndRunCabiInstaller(Probe.java:368)
at com.ca.cabi4uim.Probe.setupCabiInBundledMode(Probe.java:315)
at com.ca.cabi4uim.Probe.setupcabi(Probe.java:281)
at com.ca.cabi4uim.Probe.initOnTimer(Probe.java:620)
at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:418)
at com.ca.cabi4uim.Probe.run(Probe.java:805)
at com.ca.cabi4uim.Probe.main(Probe.java:111)
May 18 13:39:56:087 [140645354358592] Controller: Probe 'cabi' (command = <startup java>) returns no-restart code (42)
 
Environment:
UIM 8.5.1
cabi 3.2
Cause:
CABI 3.2 (Jasper server 6.3.0) installed on a not supported Operating System
Resolution:
Check if CABI has been installed on a supported OS.
The CABI 3.2 (Jasper server 6.3.0) is only supported on the below list of OS:

 

Supported Operating Systems

CA Business Intelligence JasperReports Server (CABI) 6.3.0 supports installation on 64-bit operating systems only.

Installation TypeSupported Operating Systems and Versions
WindowsRed Hat Enterprise LinuxSUSE Linux EnterpriseSolaris
Silent

Windows 8.1

Windows 10

Windows 2008 R2

Windows 2012

Windows 2012 R2

 

 

 

RHEL 5.5

RHEL 5.6

RHEL 6.4

RHEL 6.5

RHEL 6.6

RHEL 6.7

RHEL 7.1

RHEL 7.2

SUSE 12 SP1 (SUSE 12.1)

10

11

GUI

Windows 2008 R2

Windows 2012

Windows 2012 R2

RHEL 6.4

RHEL 6.7

RHEL 6.8

RHEL 7.1

RHEL 7.2

SUSE 12 SP1 (SUSE 12.1) 
Response File Based

Windows 2008 R2

Windows 2012

Windows 2012 R2

RHEL 6.4

RHEL 6.6

RHEL 6.7

RHEL 7.1

RHEL 7.2

SUSE 12 SP1 (SUSE 12.1) 
Additional Information:
TIBCO JasperReports® Server 6.3.0 Release Notes
CA Business Intelligence JasperReports® Server - 6.3.0 system requirements

Related KB's:
cabi_external probe will not start
Cabi probe v3.0 deployment problems
Unable to use UIM CA Business Intelligence Dashboards (error 403)
After deploying the CABI probe to a robot we are getting the following: (command = <startup java>) returns no-restart code (42)
Wasp probe used with CABI won't start. Controller: Max. restarts reached for probe 'wasp' (command = <startup java>)

Documentation
Installing and Upgrading CA Business Intelligence JasperReports Server with CA UIM