Connector SOI/Ehealth connection problem

Document ID : KB000005826
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Connector SOI/Ehealth connection problem

Messages error

From com.ca.usm.ucf.EhealthConnector.log

INFO [Start_Module_Thread_CA:00002_<eH_Hostname>] impl.ConnectorDbApi -156-com.ca.usm.ucf.EhealthConnector-3.4.0.0 - ConnectorDbApi::handleSQLException error code = 1017.
FATAL [Start_Module_Thread_CA:00002_<eH_Hostname>] impl.ConnectorDbApi -156-com.ca.usm.ucf.EhealthConnector-3.4.0.0 - Could not connect to eHealth Server <eH_Hostname>.

From coreapi.log
Caused by: [UCFException: errorType=0, message=Could not connect to eHealth Server., faultData={}, cause=java.sql.SQLException: ORA-01017: invalid username/password; logon denied

 

 

Environment:
eHealth 6.3.2 on Windows platform
Cause:

Incorrect user (nhuser) password informed in SOI connector installation

Resolution:

Before install the SOI connector run the nhManageUsers -showPass -user %NH_USER% in order to check the correct password