Universal, MTC & Service Discovery Connectors not visible on SOI Dashboard

Document ID : KB000112514
Last Modified Date : 30/08/2018
Show Technical Document Details
Issue:
I have installed latest SOI 4.2 in my environment. Post installation, the connector is not visible in the SOI Administrator ....connector configuration page
Connectors running on other machines are visible in the Connector Configuration page but the Manager connectors Universal, MTC & Service Discovery not showing in the Dashboard
Environment:
SOI 4.0
SOI 4.2
Windows
Cause:
The problem is with \SOI\resources\Configurations\SSA_IFW_<MachineName>.xml file is corrupt and following entry was missing...

                    <ConnectionInfo failover="TRUE"

Found below exceptions in "\SOI\jsw\logs\SAM-IntegrationServices_wrapper.log"

Reading config file: F:\Program Files (x86)\CA\SOI\resources\Configurations\SSA_IFW_<MachineName>.xml
Connector initialization failed: null
java.lang.NullPointerException
at com.ca.sam.ifw.framework.ConnectorConfiguration.getConnectorConfig(ConnectorConfiguration.java:456)

Loading XML bean definitions from class path resource [grContext.xml]
Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@3b974323: defining beans


 
Resolution:
1) Stop CA SAM Integration Services

2) As the problem with corrupt \SOI\resources\Configurations\SSA_IFW_<MachineName>.xml file, missing below line
                           
                            <ConnectionInfo failover="TRUE"

    Get this file updated with above line by copying it from other IFW server

3) Start CA SAM Integration Services