Client Automation log named dsmEventLog.log continues to grow What is it and how can you control the growth of it?

Document ID : KB000045730
Last Modified Date : 14/02/2018
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Problem:

The Client Automation Asset Management agent monitors system events from the system log on UNIX and causes a log in the

/opt/CA/DSM/logs directory to grow to a very large size and not truncate. The file that grows in named /opt/CA/DSM/logs directory

 

Environment:  

All Supported versions of CA Client Automation

Seen mostly on AIX systems but has potential to affect all supported UNIX based platforms.

 

Cause:

The Asset Management Agent from CA Client Automation Asset Management Agent installation modifies the /etc/syslog.conf file

to capture syslog information. It then pipes the information to the file /opt/CA/DSM/logs//opt/CA/DSM/logs directory but thereis no 

controlling the growth. 

 

Workaround:

The product is hardcoded to do this and can  not be changed at this time so the only workaround would be to remove the

collection module by following these steps:

1. login into the machine having this issue as the root user. 

2. caf stop

3. cd /opt/CA/DSM/scripts directory

4. run the following command 

./ dsmsyslog uninstall  

5. restart caf and the file growth will stop as it disables the interaction between the system log and the agent.