Client Automation - Red Hat Linux 6.10 appears with platform Red Hat Linux 6.1

Document ID : KB000125181
Last Modified Date : 23/01/2019
Show Technical Document Details
Issue:
Linux machine Red Hat 6.10 appears in DSM Console with patform Red Hat 6.1


Example :
In the example below, Linux Machine "Red Hat Enterprise Linux Server release 6.10 x86_64" appears as "Red Hat Enterprise Linux Server 6.1 x86_64"
 
User-added image




 
Environment:
Client Automation Agent 14.0, 14.0 SP1 or 14.0 SP2 on Red Hat Linux 6.10

 
Cause:

Red Hat Linux 6.10 is not supported/certified in Client Automation 14.0, 14.0 SP1 and 14.0 SP2

See compatibility matrix :
https://support.ca.com/us/product-content/status/compatibility-matrix/ca-it-client-manager-agent-compatibility-matrix.html

But an updated OSConfig.xml file could add the classification for this Red Hat Linux version.

 

Resolution:

1- Make sure that ClassID for Red Hat Enterprise Linux Server 6.10 x86 (5551) and Red Hat Enterprise Linux Server 6.10 x86_64 (5552) are present in mdb database
If Engine job "Default Software Contents Download Job" has been successfully executed recently they should be present.

Following SQL Query could be executed to verify this :

select * from ca_class_def where class_name like 'Red Hat Enterprise Linux Server 6.10%'

This query should return 2 rows.
 
User-added image



2- On all machines with DSM Console (DOMAIN + Remote Console) do this :
  • caf stop
  • Rename file C:\Program Files (x86)\CA\DSM\Agent\OSConfig.xml as OSConfig.xml.ori
  • Copy the file OSConfig.xml attached to this article under C:\Program Files (x86)\CA\DSM\Agent
  • caf start


3- On Red Hat Linux 6.10 machines, do this :
  • caf stop
  • mv $CA_ITRM_BASEDIR/Agent/OSConfig.xml $CA_ITRM_BASEDIR/Agent/OSConfig.xml.ori
  • Copy the file OSConfig.xml attached to this article under $CA_ITRM_BASEDIR/Agent
  • caf start
  • caf register all

 
File Attachments:
OSConfig.xml