Client Automation - Deployment Wizard - Unexpected TELNET prompt

Document ID : KB000115573
Last Modified Date : 21/09/2018
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Issue:

Deployment Job for Windows ITCM Agent using Deployment wizard remains in status "Deploying primer" during several minutes.
 
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Then it fails with error "Unexpected TELNET prompt."
 
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Environment:

Target machine running on Windows OS
Cause:

This problem could indicate a CAM installation problem on target machine.

On target machine check if CAM is correcly installed and running fine.
  • Check if following command is working fine :
camstat -n

If camstat is not a recognized command :

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check under C:\Program Files (x86)\CA\SC\CAM\bin that there are only few files.
 
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This indicates that CAM is not correcly installed.
 
  • If all is correct in above checking, check if file C:\Program Files (x86)\CA\SC\CAM\camclient.cfg contain a line for DMPRIMER_12.0 :
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If the line is not present, there is a CAM installation problem too.

 
Resolution:

In order to resolve the CAM installation problem do this :
 
  •  Delete the registry key :
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\CAMessageQueuing
(or HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\CAMessageQueuing on Windows 32 Bits).
 
  • Delete the directory C:\Program Files (x86)\CA\SC\CAM
 
  •  Under Control Panel/Programs/Programs and Features, uninstall "CA DSM DMPrimer"
 
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  •  Then attempt again the installation with Deployment Wizard.