Clearing Duplicate api?s

Document ID : KB000045548
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue:

Duplicate API's.

Environments:

CA API portal - All versions

Cause:

This usually occurs when the API ID in the "set as portal managed" assertion changes.

Resolution:

1. Login to policy manager.
2. Identify all of your API's that are portal managed.
3. Open the "set as portal managed" assertion, and note the API ID there.
4. Compile a list of all of your API ID's from your portal managed services in policy manager
5. Cross-reference them with the xml file names that exist in the API portal's CMS, under:/sitebuilder/content/groups/APIs
6. The xml files that are not association with an existing API in the policy manager (list from step 4) should be deleted. The xml file names are API ID's, so that's the value that you cross-check.

Note: We would suggest taking a backup of the xml files prior to deletion, just to be on the safe side