Cisco 4948 with IOS 12.2(20)EWA will not send traffic across SPAN port ( Legacy KB ID NTQ 00000927 )

Document ID : KB000051412
Last Modified Date : 14/02/2018
Show Technical Document Details
ISSUE
A SuperAgent 7.x Collector is configured and running as suggested by Support but even though the SPAN configuration is correct, no traffic is being sent across the SPAN port on a Cisco 4948 series router running IOS 12.2(20)EWA.

DETAILS
This is a known Cisco bug in IOS 12.2(20)EWA on a WS-C4948 system, Cisco bug CSCef69929. You will not see any packets to or from the Collector on the Monitor NIC even though the SPAN configuration is correctly configured. From the Cisco bug write up: "WS-C4948:Continuous Blocked transmit queue HwTxQId messages: When a traffic carrying port has been disconnected or disabled on WS-C4948 system, the following error messages may be seen on console. If this port is then connected or enabled, no traffic will pass through it." These errors will be seen in the console log files on the router: %C4K_HWPORTMAN-4-BLOCKEDTXQUEUE: Blocked transmit queue HwTxQId1 on Switch Phyport 18, count=342141 %C4K_HWPORTMAN-4-BLOCKEDTXQUEUE: Blocked transmit queue HwTxQId3 on Switch Phyport 18, count=342142 %C4K_HWPORTMAN-4-BLOCKEDTXQUEUE: Blocked transmit queue HwTxQId1 on Switch Phyport 19, count=342143 %C4K_HWPORTMAN-4-BLOCKEDTXQUEUE: Blocked transmit queue HwTxQId3 on Switch Phyport 19, count=342144

RESOLUTION
Verify that this really is the issue by doing a packet capture on the SPAN port and double checking the router model and IOS number. If this is in fact the issue, follow the workaround or solution below. Workaround Restting or reloading the system will fix the problem. Solution Upgrade to at least IOS 12.2.(25)EWA2. Versions prior to this will not completely fix the issue. Refer to Cisco Bug CSCsb01311 http://www.cisco.com/cgi-bin/Support/Bugtool/onebug.pl?bugid=CSCsb01311